  Description: Tables are the easiest way to lay out pages in HTML 4.01; it is useful to learn how tables work before moving on to table-less design. CSS (cascading style sheets) can provide simple text formatting as well as intricate (table-less) layouts.

Table Basics
Designers can create complex, professional page layouts with the use of tables. Tables offer the ability to position HTML elements as well as present information in an organized manner. Tables, when used creatively, can also enhance the design of a page. For example, the page your viewing now was composed with the use of several tables. 

In this section you will learn how to create, modify , and use tables as a design tool within Dreamweaver.

So what is a table anyway? If you've used a spreadsheet or a program such as Microsoft Word, you probably already have an idea. A table is a way of organizing data, or information. This is done by using headers, rows and columns. Netscape introduced the table tags with version 1.2; this set of proprietary tags allowed designers to use a grid layout, something that was not possible prior to this innovation. However, the tags were not designed to hold "design" information -- they were designed to hold "tablular data" and this foundation is reflected in the code names. 

Tables are composed of rows, columns, and cells, just like they are in a word processing program. And we can "merge" cells, just like we do in a word processing program. For example, here is how a software company's inventory might be organized:

	Software Inventory

	25
	Adobe Photoshop

	15
	Macromedia Dreamweaver

	20
	Microsoft Word

	25
	Macromedia Flash
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The example above was created with a Table Header, 2 columns, and 4 rows. You will learn how to create these and more.

Basic Table Code 

<table border="1" cellpadding="5" cellspacing="0" width="400">


<tr>



<td>




Some information



</td>




<td>




More information



</td>


</tr>


<tr>



<td colspan="2" bgcolor="#ccffff">




merged cells



</td>



</tr>

</table>

It looks like this: 

	Some information 
	More information 

	merged cells 


Creating a Table

Tables can be created within Dreamweaver from the Insert Menu, by selecting Table, or from the Objects Palette by clicking on the Table Icon. [image: image2.bmp]Either option brings up the following Dialog Box:
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Several fields must be defined before the table is inserted:

· Rows: How many rows in the table

· Columns: How many columns in the table

· Table width: The width of the cell may be specified in percent or pixels. Percent is relative to the size of the browser window being used to view your web page. On the other hand, if you specify pixels, and the number of pixels is greater than a screen width, the person viewing your page will be forced to scroll horizontally.

· Border thickness: The thickness of the table border. This is a number in pixels. A border of 4 or 5 makes the border look like a picture frame. A border of 0 makes your table invisible.
· Cell Padding: Space around a table data cells item. The example shows the cellpadding set to 10 pixels 
	A
	B
	C

	D
	E
	F


· Cell Spacing: Amount of space around a cell. The example shows all cellspacing set to 10 pixels.
	A
	B
	C

	D
	E
	F


The following fields are optional and make data tables accessible to screen readers:

· Header: Specifies table header either on none, left, top, or both.  
· Accessibility: If the table you are inserting is not a data table, do not select any of the accessibility options, as non-data tables do not need these additional accessibility features.
Once you have defined the table, click OK and it will be placed on your page. It will look something like this:

[image: image4.png]



Each one of the boxes is a table cell. From there you can enter text by simply clicking once inside the cell and then typing. You can also add images, forms, and just about every other HTML element.

Table Properties

Before you can modify your table, you must select it. This can be done in different ways:

· By clicking near the edges of the table with the mouse

· By putting the cursor inside any cell and selecting Table | Select Table from the Modify Menu

· By clicking on the <table> tag in the lower left corner of the screen.[image: image5.png]<bodys <tables <tr> <td>




When the table is selected, you'll notice a black box surrounding it. From here you'll be doing a lot of work from the Properties Toolbar. Here is a screenshot of the toolbar when the table is selected:
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You can modify the table at any time from the Properties toolbar. Here is an explanation of the fields:

· Table Id: This is where you would name the table. This really only comes into effect when you will be using a Javascript to call the table.

· Rows: The number of rows. Changing this will change the table. Only do this if there is no data inside the table. You'll learn how to modify the table with data inside in the next section.

· Columns. The number of columns. Changing this will change the table. Like rows, only do this if there is no data inside the table.

· Width (W): This is the width of the entire table. Use the drop down menu to the right to specify whether the width is in pixels or a percentage.

· Height (H): This is the height of the entire table. Only change this if you have a fixed height within the table, such as an image. The height of many HTML elements will vary on many platforms. If you're at 800 x 600, and specify a height for that resolution, there will be empty space at the end for someone at a larger resolution.

· Cellpad: Specifies the space between the table border and the cell.

· CellSpace: Specifies spacing between table cells. 

· Align: This is where you set the alignment of the table on the page. The options are left, center and right.

· Border: The size of the border in pixels.
· Bg color: Specifies a table background color in Hexadecimal format.

· Brdr color: Specifies the border color for the table in pixels.

· Bg Image: Specifies a file to be used as the table background. A file can be chosen from the hard drive by clicking on the Folder icon.
· [image: image7.bmp] Clear column widths
· [image: image8.bmp]Convert Table Widths to Pixel
· [image: image9.bmp] Convert Table Widths to Percent
· [image: image10.bmp] Clear Row Heights

· [image: image11.bmp] Convert Table Heights to Pixel

· [image: image12.bmp] Convert Table Heights to Percent
Cells and Rows

You can also modify cells and rows individually. Rows can be modified by selecting the entire row. This can be done by holding down the CTRL (Command on Mac) key and clicking in each individual cell of the row, or by clicking on the <tr> tag in the lower left corner.

Table cells can be selected simply by having the cursor inside the cell. They also can be selected by clicking with the CTRL (Command) key, or by clicking on the <td> tag.

The Properties Toolbar does change. The top part is identical to the default text Properties, with alignment, text formatting, etc. The expanded Properties are similar to the Table Properties, but there are some differences.
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· Horz: Horizontal alignment. This affects only the elements inside the cell. The options are Left, Center and Right.

· Vert: Vertical alignment. This affects the orientation of the elements within the cell relative to other cells.

· W: Width of the cell. This can be a number or a percentage. If it is a percentage, the % sign must be added.

· H: Height of the cell. This must be a number in pixels.

· No Wrap (checkbox): This prevents elements inside the cell from wrapping.

· Header (checkbox): This designates that the cell is a Header Cell (TH). This makes any text inside centered and bold.

· BG (top): Background image for the cell.

· BG (bottom): Background color for the cell.

· Brdr: Border color for the cell.

Here is a sample:

	Header Cell
(blue background) 
	Header Cell

	width 50%
Vert: middle 
	this cell doesn't require a width. It takes the remainder.

	Vert: top
Horz: center 
	Vert: middle
Horz. left
border: purple 


 You should now understand how to define and change many table elements within Dreamweaver. Next you will learn how to control your table with elements already inside.

Modifying Your Table

One of the advantages of using Dreamweaver is the simple fact that it is a WYSIWYG program. While designing you can see how changes will look in the browser (to a degree) without having to preview it. This is one of the many ways which Dreamweaver can save the Web Designer plenty of time. This gives you the ability to make slight changes while you are designing. You may decide that you need to add an extra row, or delete an extra column. There are several ways to do this as you go.

The context menu is extremely helpful for making modifications. While you have your cursor inside a cell, you are able to right click (CTRL click for Mac), select Table, and there are several options available for making modifications. We will call this submenu the Table Menu.

Note: This same submenu can be accessed from the Modify Menu by selecting Table.

Adding Rows and Columns
You can add a row or a column by selecting menu Modify > Table > Insert Row or Insert Column. Or right-click inside a cell and select Table > Insert Row or Insert Column. This will be added above the selection. This means that a row will be inserted above the row your cursor is currently in, and the column will be inserted to the left of the column your cursor is currently in.

Deleting Rows and Columns
You can also delete rows and columns easily by using the Table Menu. Simply place your cursor in the row or column you would like to delete, access the Table Menu, and select Delete Row or Delete Column.

You can delete multiple rows and columns by selecting all the cells within. This can be done by holding down the CTRL (Command for Mac) key and clicking on each cell individually.

Spanning Columns and Rows

Unless you are familiar with HTML, you are probably not familiar with Column and Row Spanning. It can be a difficult concept for some, but is well worth spending the time to learn it. 

You can specify that a certain table cell will span multiple columns or rows. In HTML, you must specify the number of cells it will span. In Dreamweaver, you are allowed to simply increase and decrease the span by one. 

Here is an example of Column Spanning:

Standard 2 row, 3 column table:

	 
	 
	 

	 
	 
	 


Same table with the first cell given a Column Span of 1(increased once)

	 
	 

	 
	 
	 


Same table with the first cell given a Column Span of 2 (increased twice)

	 

	 
	 
	 


As you can see, the top cell spanned the entire row.

Here is the same example for a Row Span:

	 
	 
	 

	
	 
	 


The first cell of this table was given a Row Span of 1 (increased once).

This can be done easily. Click inside the cell you would like to span. In the case of the example, that would be the upper left cell. While your cursor is in there access the Table Menu and select Increase Row Span, or Increase Column Span.
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If you decide to change your mind, you can decrease the span in the same fashion, by selecting Decrease Row Span or Decrease Column Span.

Here is an example of how the first example could be transformed into a simple page design. 

If you've followed up to this point, you are almost capable of producing professional designs. We just have one page to go.




Nesting Tables

Nested tables means placing (nesting) a table within another table. Doing this can give the designer even more control over positioning with a table driven page.

It is done quite easily. Simply insert a table while the cursor is within the cell you would like to place the table. 

Here is an example:

	 
	 

	 
	 


Here is the nested table:

	Nested table



	
	 

	 
	 


The nested table was 1 column and 1 row, and given a border of 5 to distinguish it from the original table.

Before you start going crazy with nested tables, I should warn you that this can slow down your page's load time. Browsers display tables by rendering what is inside before rendering the rest of the table. This means that if you have 5 nested tables within 1 container table, the browser must render everything inside before the container table will displayed. This is especially true with Netscape browsers. It is a good idea to test your designs in both browsers before you publish.

Nesting tables is more of a design tool than anything else. 
http://www.ipowerweb.com/build/software/dw/tutorial/820.htm
http://www.internet4classrooms.com/using_dw_tables.htm

