
In this section, you will learn:

· The Dreamweaver Interface  

· Dreamweaver Views  

· Toolbars  

· Properties Inspector  

· Dreamweaver Panels 

What is Dreamweaver MX 2004?

Dreamweaver is a powerful but easy-to-use web site development program that bridges the gap between designer and developer. Although it includes advanced features for developing complex web-based data-driven applications, Dreamweaver's intuitive interface and extensive libraries let even the novice web designer develop a professional web site quickly and easily.

The latest version, Dreamweaver MX 2004, touts a more streamlined interface, with tighter categories by which commands are grouped (promising less clutter without sacrificing ease of use), and enhanced Cascading Style Sheet (CSS) support.

Exploring Dreamweaver

Dreamweaver's interface makes it easy to design and manage both simple and complex web sites by providing a point-and-click interface that simplifies most tasks. Designers can drag and drop page elements in Design view, while developers can work directly with the page's code, making use of the various tools Dreamweaver provides for ensuring correct syntax.

Common commands are accessible from the toolbars, which are grouped by category, and in the Property Inspector, which lets you specify attributes for the text and objects you insert. Many of these commands are also available in the Dreamweaver menus. Additional commands are available in the panel groups found on the right side of the Dreamweaver window; you can expand and collapse these groups as necessary.

Document Window and Toolbars

The main workspace in Dreamweaver is the Document window. This is where you add elements to your web page, either using Dreamweaver's WYSIWYG (What You See Is What You Get) interface, or by typing the HTML code directly into the window.
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Dreamweaver offers three document views: Design view, Code view, and Split view, which displays both Design and Code views in a split window. In Design view (shown above), you can draw individual layers and table cells on the page, drag and drop graphics, and type text as you would in a word processor. The page appears as it will to viewers.

Code view (shown below) lets you edit the HTML and any other code (such as scripts) included in the page.
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Dreamweaver's live syntax coloring helps you distinguish between different kinds of tags. In addition, when you type in Code view, Dreamweaver provides code hints based on the first few letters you type. For example, if you type a bracket (<), a menu pops up with a list of valid tags:
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When you select a tag from the list, Dreamweaver inserts it into the document. For example, select a from the list and press Enter to insert it. Then press the space bar on your keyboard. Another menu pops up with a list of additional elements.
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To complete the code to insert a hyperlink in your document, select href from the list and press Enter. Dreamweaver inserts the HTML code using the correct syntax, and even lets you browse for the file you're linking to.
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Notice that it also inserts the quotation marks that are required to enclose the link.

[image: image6.jpg]


Tip: To learn more about HTML tags, open the Reference panel of the Code panel group. Here, Macromedia has included the O'Reilly HTML Reference, which provides a list of HTML tags and their attributes.

Split view splits the Document window to display both Code and Design views. This is useful when you want to view the effects of any changes you're making to the HTML code.
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Tip: Your changes may not appear in the Document window until you save the document or click the Refresh Document View button [image: image8.jpg]


 on the Document toolbar.

Document Toolbar

Use the buttons on the Document toolbar, located just above the Document window, to switch between Code, Split, and Design views.
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The Document toolbar also contains commands for naming, previewing, and publishing the current document:

	  
	Title - Lets you specify a title for the page, which appears in the title bar of the browser's viewer.
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	No Browser/Check Errors - Provides a menu of options for checking browser compatibility with the page.
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	File Management - Provides a menu of file management options for the page, including a command to upload the page to your web server.
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	Preview/Debug in Browser - Lets you preview the page in the browser you select.

	[image: image13.png]



	Refresh Design View - Refreshes the appearance of the page in Design view after you've made changes to it in Code view.
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	View Options - Lets you specify various settings for the current view.


If you don't see the Document toolbar, open the View menu and select Toolbars, and then Document to show it.

Standard Toolbar

The Standard toolbar, located just below the Document toolbar, contains the same commands you'd find on most standard Windows toolbars:
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	New - Create a new document.
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	Open - Open an existing document.
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	Save - Save the current document.
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	Save All - Save all open documents.
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	Cut - Cut the current selection.
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	Copy - Copy the current selection.
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	Paste - Paste the contents of the clipboard.
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	Undo - Undo the last action.
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	Redo - Redo the last action in the undo history.


To display the Standard toolbar, open the View menu and select Toolbars, and then Standard.


Insert Bar

The Insert bar contains most of the commands you'll use to add elements to your pages. These include images, hyperlinks, tables, forms, and multimedia objects. These commands are grouped into categories, which you can choose from the drop-down menu at the left side of the toolbar.
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Common - The default category, which contains commands for adding hyperlinks, tables, images, and multimedia objects.
Layout - Used for designing the layout of your page, with commands for tables, layers, and framesets.
Forms - Contains commands for adding form elements to your page.
Text - Contains commands for applying various formatting to the text on your page, as well as for inserting special characters.
HTML - Lets you select various HTML tags to insert into your page.
Application - Contains commands for adding database elements to your page.
Flash Elements - Lets you insert a Macromedia Flash movie into your page.
Favorites - Lets you customize your own toolbar by grouping your favorite commands.

You'll be introduced to many of these commands in subsequent sections of this tutorial.

To show or hide the Insert toolbar, open the View menu and select Toolbars, and then Insert.
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Tip: In Dreamweaver MX 2003, the Insert bar categories were displayed as tabs along the top of the toolbar. Dreamweaver MX 2004 includes this option in the drop-down menu on the left side of the toolbar: simply select Show as Tabs
Property Inspector

The Property Inspector lets you specify the properties of the text or object that's currently selected on your page. The fields and buttons shown in the Property Inspector depend on the type of selection; for instance, when text is selected, the Inspector provides you with fields for changing the font style, type, size, color, and alignment.
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Status Bar

The status bar is the small row at the bottom of the Document window containing the Tag Selector. The Tag Selector displays the HTML code surrounding your cursor. You can select one of these tags to modify simply by clicking it with your mouse.
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The status bar also includes a Download Size/Download Time drop-down list, which lets you select a window size for your document. The size of the window (along with the sizes of the objects included in your pages) impacts the speed at which a viewer can download the page. When you select a size from this menu, Dreamweaver automatically updates the speed displayed to the right of the window size on the status bar.

Panel Groups
The Dreamweaver panel groups, displayed vertically on the right side of the Dreamweaver window, group together the related information and commands you'll use to design your pages and build and publish your web site. The commands available in the panel groups are far more extensive than the ones you'll find on the Insert bar, which contains the most common Dreamweaver commands.

Each panel group contains one or more panels, similar to categories on the Insert bar. To expand a panel group and view its available panels, click the arrow in the upper left corner of the group.
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To access a particular panel, simply click its tab.

Finally, each panel includes an Options menu in the upper right corner, which contains additional options for that panel.
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Design Panel Group

The Design panel group has two panels: CSS Styles and Layers. Use CSS Styles to maintain the styles in your document, and to create and attach style sheets. The Layers panel displays all the layers in the current document, which you can show or hide, lock or unlock, rearrange, and rename.
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Code Panel Group

The Code panel group helps you work with the code in your page, including HTML, JavaScript, and ASP. The Snippets panel lets you save code snippets, which you can reuse later, while the Reference panel includes a comprehensive HTML reference library.
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Application Panel Group

The Application panel group is used to include dynamic content in your web sites. Here, you can specify a data source, define recordsets, and add advanced server behaviors.
[image: image33.png]v Appl
Databases I

()(=) asp vescript

B Tables
A vews
B stored procedures




Tag Inspector

The Tag Inspector displays all the attributes of your page elements. Here, you can modify any attribute of a selected HTML tag by typing directly into the attribute's corresponding box, or by selecting it from a menu that pops up when you click inside the box.
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In addition, the Behaviors panel lets you add client-side behaviors to your page using JavaScript inserted by Dreamweaver. Unlike the behaviors in the Application panel, client-side behaviors do not require a server technology in order to run. Examples of the behaviors you can add include: Check Browser, Go To URL, and Swap Image (used to create rollover effects).

The Relevant CSS tab is similar to the Tag Inspector; you can use it to change the properties of the style applied to the current selection. 

Files Panel Group

The Files panel group has two panels: Files and Assets. The Files panel is used to manage your web site files, and to upload and download files to and from your web server. You can also use this panel to define new web sites and to quickly switch between your various sites.

Note: In previous versions of Dreamweaver, this was called the Site panel.
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The Assets panel is used to manage the reusable elements of your web pages, including object libraries and templates.
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Section Learning Goals
In this section, you learned:

· The Dreamweaver Interface 


· Dreamweaver Views 


· Toolbars 


· Properties Inspector 


· Dreamweaver Panels 
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Section Learning Goals
In this section, you will learn:

· How to create a website  

· Managing site files  

· Create an HTML webpage  

· Defining document properties  

· Uploading a webpage 

Creating Your First Web Site

Creating a Local Site

You define a web site using the Site Definition wizard. When defining the site, it isn't necessary to specify the remote settings for uploading your files; however, you will need to enter these settings before you can publish the site.

1.      Open the Site menu and select Manage Sites, or click the Manage Sites link on the Files panel.
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The Manage Sites dialog opens.

2. Click the New button and select Site from the menu that appears. 
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Tip:You can also create a new site from the Dreamweaver Start page: Under Create New, select Dreamweaver Site.

The Site Definition wizard opens. The Basic tab leads you through the site definition process step-by-step; the Advanced tab lets you specify advanced settings.
Refer to http://www.brikee.com/webnotes/sitemanagement.pdf
The Files panel now displays the root folder for the site you defined.

Creating an HTML Page

To create a new HTML page:

1. Open the File menu and select New. 

The New Document dialog opens. The General tab contains various document types to select from, including basic HTML pages, dynamic pages that use server technologies, style sheets, and pre-built designs.
The Templates tab will contain any templates you define for the site.
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2. In the General tab, select the Basic Page category and HTML. 

3. Click Create. 

A new HTML page opens in the Document window.

4.      To save the file, click the Save button on the Document toolbar, or open the File menu and select Save.
In the Save As dialog, browse to the location of your site folder (if necessary), enter a file name, and click Save.
The file now appears in the Files panel.
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Tip: To create and save a new file in one step, right-click a folder in the Files panel and select New File.
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Section Learning Goals
In this section, you learned:

· How to create a website 


· Managing site files 


· Create an HTML webpage 


· Defining document properties 


